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Prerequisites:                                                                                                                          
Basic knowledge of using a computer and mouse, basic knowledge of the internet. 
Course Objectives:                                                                                                                 
When you are finished working your way through the first part of this course, you’ll be able to: 

1. Explain basic concepts about the Internet, identifying basic issues concerning proper site design, and 
navigating in the Dreamweaver environment. 

2. Do basic website planning. 
3. Define a site in Dreamweaver to organize and maintain the web pages; and create a basic web page 

by typing text and applying character and paragraph formatting. 
4. Use Site Panel to create and organize files and folders. 
5. Insert images, set image properties, create and format tables. 
6. Add links within a site, specify external links as well as use images as links. 
7. Create a basic template. 
8. Upload a site to a remote web server. 

 
Some background knowledge: 

Planning Web Sites 
When creating a Web site, it is helpful to do some planning before starting work in Dreamweaver. A little bit of 
time planning your site can save a lot of work later on. The first thing to think about is the purpose of your site. 
What do you want you site to do? Why are you creating a site? Why will people come visit your site? It can be 
helpful to look at sites with similar topics. This can give you an idea of what to include or not include on your 
site. 
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After deciding on the purpose of your site, then think about who will visit your site. Are they new to the Internet 
or experienced Web surfers? What kind of computer equipment will your site visitors have? Experienced Web 
surfers might be more likely to have fast Internet connections with the latest web browsers. Occasional or 
novice surfers might not have a fast connection and might not always download the latest browser. Will the site 
visitors be savvy computer users? Probably most importantly, what will they want to do on your site? 
 
After you have determined the purpose of your site, as well as its prospective audience, then you can start to 
organize the content. What topics or pages will you have on your site? You don’t have to know exactly what 
will be on each page, but get a rough idea of how many pages you’ll have and the topic for the page. Does the 
content for the Web site already exist in brochures, documents and images, or will it have to be created? It can 
be helpful to make a list of what you already have for the Web site and what needs to be created. 
 
The next step is to group and organize the information. Create an outline or site diagram for your site. How will 
information flow? How will site visitors navigate through the site? To wrap up the planning process, you will 
need to think about what you want the site to look like. Again, looking at other sites can be helpful in 
determining how visitors will navigate though the site, what colors you want to use, and other design ideas. 

Introduction 
In Dreamweaver, a site generally consists of two parts: a collection of files on a local computer (the local site), 
and a location on a remote web server that you upload the files to when you’re ready to make them publicly 
available (the remote site). You use the Dreamweaver Files panel to manage the files for your site. 
 
The most common approach to creating a website with Dreamweaver is to create and edit pages on your 
desktop PC, and then upload copies of those pages to a remote web server for viewing on the web.  
For this part of the lesson we will: 

1. Learn about Dreamweaver sites 
2. Set up your project files 
3. Define a local folder 

Learn about Dreamweaver Sites 
In Dreamweaver, the term “site” can refer either to a website or a local storage location for the documents that 
belong to a website. The latter is what you need to establish before you begin building your website. A 
Dreamweaver site organizes all of the documents associated with your website and lets you track and maintain 
links, manage files, share files, and transfer your site files to a web server. 
 
A Dreamweaver site consists of two main parts, depending on your computing environment and the type of 
website you are developing: 
Local folder – your working directory. Dreamweaver refers to this folder as your local site. The local folder is 
usually a folder on your hard drive. 
Remote folder – where you store your files, depending on your environment, for testing, production, 
collaboration, and publication. Dreamweaver refers to this folder as your remote site. The remote folder is a 
folder on the computer that’s running your web server. The computer running the web server is often the 
computer that makes your site publicly available on the web.  
 

Set up your Project files 
When you create a local site, you can place any existing assets (images or other pieces of content) in the local 
site’s root folder (the main folder for the site). Then when you’re ready to add content to your pages, the assets 
are there and ready for you to use. 
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Define a local folder 
You must define a Dreamweaver local folder for each new website you create. The local folder is the folder that 
you use to store working copies of site files on your hard drive. If you don’t define a local folder, certain 
features in Dreamweaver cannot work properly.  
Defining a local folder also allows you to manage your files and transfer files to and from your web server by 
using a number of file-transfer methods. 
 

Steps to set up a site: 
With Dreamweaver open: 

1. Click on Menu bar “Site” and then trace to and click “New Site”. 
2. When the Site Definition dialog box pops up asking what you’d like to name your site, please type in 

“dreamweaver 1” 
3. The http address of your site for this class will be: 
http://plaza.ufl.edu/gatorlinkusername Click “Next” 
For the purpose of this class, we will leave the setting at “No, I do not want to use server technology”. 
4. Click “Next” 
5. How do you want to work with your files during development? 
Select “Edit local copies on my machine, then upload to server when ready 
6. Where on your computer do you want to store your files? 
Click on the little file folder to the right of the question above (in the dialog box) 
You can now navigate to the desktop and select the dreamweaver 1 folder. 
7. Click “Next” 
8. How do you connect to your remote server? 
Click on the little arrow to the left of the first selection and click on FTP. 
For the second box, type “plaza.ufl.edu” 
9. What is your FTP login? 
Please type in your gatorlink username. 
10. What is your FTP password? 
Please type in your gatorlink password. 
11. Please click on the advanced tab at the top of the dialog box. Put a check mark in the box “Use passive 
FTP” and then switch back to the basic tab. 
11. Click on the “Test Connection” button 
You should see the following message: 

 
 

12. Click “OK” and then “Next” 
13. For the purpose of this workshop, we will select  
“No, do not enable check in and check out.” 
14. Click “Next” 
15. Click “Done” 

Now all of our site files and assets will show in the Files Panel to the right of the Dreamweaver screen. 
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Creating a New Document 
Macromedia Dreamweaver CS3 offers a flexible environment for working with a variety of web design and 
development documents. 
In this section, we will complete the following tasks: 

• Create a new document via the New Document dialog box 
• Save a web page 

1. To create a new document in Dreamweaver, start by clicking the “File” menu. 
2. Trace to and select “New” 
3. The General tab enables you to create a new blank page or use a pre-designed page. 
4. Please select the “Basic page” category. 
Dreamweaver CS3 includes a variety of document types. For today’s class, we will use the default 
document type, XHTML 1.0 Transitional. 
5. To create the new document, please click the “Create” button. 
Dreamweaver now creates a blank document. 
6. Give this document a title. We will call it “Universal Design”. 

 
Next, we will save the newly created web page.  
7. Please select “File” and then “Save” 
You should save your home page as index.html. This will ensure your site visitors don’t have to type 
the file name in their browser’s address bar to locate your home page. 

Creating a Table-based Page Layout 
Tables are a powerful tool for presenting data and for laying out text and graphics on an HTML page. You can 
use tables to create your layout quickly and easily. The rows and cells of the table effectively act as containers 
for the content you’ll add later. 
We will complete the following tasks: 

1. Insert a table into a Dreamweaver document 
2. Set table properties 
3. Insert an image 
4. Add color to the page 

A table provides a framework to hold content and images neatly in a fixed location.  Once you have inserted a 
table into your document, you can edit it by clicking on the corner of the table.  This will bring up a variety of 
options in the Properties panel. 

Inserting a table 
1. Be sure you’re on the index page. 
2. Now we will add a table that will hold text, graphics and links. 
3. To do this, make sure you have the “Common” tab selected on the Insert bar. 
4. Click on the “Table” object. 
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Setting the table properties 
1. In the Rows text field, please enter 2. 
2. In the Columns field, type 2. 
3. In the Table Width text box, enter 775. 
4. In the Cell padding box, enter 20. 
5. Click OK to proceed. 
A table with two rows and two columns appears in your document. The table is 775 pixels wide with no 
border, and 20 pixel cell spacing. 

• At the bottom of the screen is the properties window.  
• We will change the Align from Default to Center. 

To prepare the table for use on our page: 
1. Drag select the top row (both cells) 
2. Right-click on the selection and a drop down menu will appear. 
3. Select Table, trace to and click Merge Cells. 

Adding a Background Image to a Table Cell 
1. Click in the merged cell. 
2. Properties for the cell will show at the bottom of the window.  
3. We will be adding a background image to the cell.  
4. We’ll need to click the folder next to Bg to browse and find our image. 

 
5. When the “Select Image Source” dialog box pops up, select the “background.gif” and then click OK. 
6. Click back in the top cell where we just put the background image.  
7. Type “Universal Design” 
8. Drag-select the text 
9. In the properties window, type “200” in the size box and click the down arrow next to size and select 

“%”. 
10. Click the font color box and select white. 
11. Click the Align right button to put the text to the right edge of the cell. 

Working with Text 
1. In our “Files” panel, double-click the content folder; double-click the index.txt file to open it in the 

document window. 
2. We will select all of the text by drag selecting it. 
3. We will copy the text by doing the keyboard shortcut, Ctrl + C. 
4. Click back on index.html 
5. Click in the second column in the second row 
6. Press Ctrl + V on the keyboard to paste in our text. 
7. Drag select Universal Design and delete it. 
8. Drag select the heading Accessibility 
9. For Format, click on the down arrow and select Heading 2 
10. In the properties window, set the Font to Verdana, Arial 
11. Set the size to 150 %. 
12. Change the text color to: #000066 (which is a dark blue) 
13. Do the same steps for the headings “Usability” and “Why Consider Accessibility?” 
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Insert an Image 
Even a relatively simple image can give a webpage visual interest and reinforce the message of the text.  
However, a poor image can make the best page unreadable.  

• Be sure that graphic files are “saved for the web” and the file size is a small as possible.  Graphics that 
take too long to download will encourage viewers to move to another site. 

• Do not re-size your graphics in Dreamweaver because this will add to the download time.  Edit the 
graphic in an image program so that it is the correct size.  

• Background graphics should not be busy.  Consider the contrast between the background and text. 
• Use the Alt-tag feature to describe graphics.  This will assist viewers who may be using a screen reader. 
• Keep copyright laws in mind when choosing graphics for your webpage. 

 
We will insert an image to add visual interest to our text. 

1. Click before the ‘A’ in the word Accessibility in the first paragraph. 
2. Click on the image button on the insert toolbar. 
3. The ‘Select Image Source’ dialog box will appear. 
4. Select the magnify.jpg image. 
5. For the Alternate text, type: 

Screen shot of a screen enlarger and then click OK. 
6. Use the arrow next to Align at the bottom right of the property panel and select ‘Right’. 
7. Later we will change the background color of our page so we’ll need to change the background color of 

this cell so that it will remain white once we’ve changed the background color of the page to a darker 
color. 

8. Right above the word Properties in the property inspector, click on the <td> to select the cell, then 
change the Bg color box to white. 

Create the Navigation Pane 
1. Change the color of the lower left table cell to #E6E6D0 
2. In the Properties panel, change Horz to Left and Vert to Top. 

This is where we will put our text links to our other pages once we have created them. 
3. Type ‘Universal Design’ and then hit enter 
4. Type ‘Assistive Technologies’ and then hit enter 
5. Type ‘Contact’ and then hit enter 
6. Drag-select the three lines of text and apply bullets by clicking the bullets button in the Properties panel. 

Create Links within a Web Site 
When your links refer to files within the same Web site, you do not need to specify the domain name or 
directory that the site files are located inside. If the page the page that you are linking to is stored in the same 
folder (or directory) as the current page, simply use the name of the file as the link. If the page you are linking 
to is located within a subfolder of the site folder, you only need to reference those subfolders within the site 
folder. 
We will now create various links between the pages within the site. Once we select the text or image that we 
want to use as the link, we can use one of four basic techniques to create links: 

• Type link references manually 
• Use the Hyperlink button in the Insert bar and enter link information in the Hyperlink dialog box 
• Use the Point to File icon in conjunction with the Site panel 
• Use the Browse for File button in the Properties inspector. 
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We will create links between the pages in your site to make it easy for a viewer to access each page. 
1. Drag-select the text “Universal Design” in the navigation cell. 
2. In the Properties panel, you will see a blank section next to the word Link 
3. Click and type “index.html” 
4. Drag-select the text “Assistive Technologies” 
5. Click in the Link section in the Properties panel and type “technologies.html” 
6. Do the same steps for Contact 

 

Templates 

Why use Templates? 
Templates in Dreamweaver are designed to help you create pages that share the same design and layout, but 
have different content. The biggest advantage is that when make a change to something in a template, 
Dreamweaver automatically updates all the files that are based on that template. 

Creating a Template 
For index.html,  

1. Choose from the menu File > Save as template (Be careful not to use the Save As option.).  
2. Click Yes to Update Links. 

 

 
Figure 1 Save As Template window 

3. For the Save as field, type in index.  
In your Files Panel, you’ll see that Dreamweaver created a new folder in your site called Templates, and inside 
is a file called index.dwt. The dwt extension is used for all Dreamweaver templates. 
 

 
Figure 2: Files panel after creating template 

Creating editable regions 
Dreamweaver creates a new html file that is an exact copy of the template.  
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Editable regions are places in the document that can be different from the template file. When we have a 
template, usually our header, footer, and menu are the things that we want to stay consistent from page to page 
and it’s our content that should be editable. 

To make a region of the template available for editing, we have to define our editable region. 
1. Open index.dwt. (Note: look in the Templates folder in your files panel.)  
2. Select all the text in the content cell. 
3. From the menu, choose Insert > Template Objects > Editable Region. 
4. Name the region “Content”, and then click Ok. 

You should see a blue outline around all the content in the editable region and a label with the region’s name. 
 

 
Figure 3: Editable region in a template 

Creating new files based on template 
To use templates, you create a new file based on the template. This is different from the normal way to create a 
new file.  

1. In the menu, select File > New.  
2. Click the Templates tab to see a list of available templates. 

 

 
Figure 4: Creating a new file from the template 

3. Select the “Dreamweaver 1” site, then the index template. You’ll see the page in the Preview window. 
4. Click Create. 
5. Save this new file as index.html which will replace the original which is not based on the template. 

 
 
 
 
 
 

Converting existing files to the template 
Now we need to convert technologies.html and contact.html to the template. The content from these files need 
to be replaced with new files based on the index template. 
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1. In the new untitled page based on the template, select all the text in the Content region and delete the 
text. We’ll replace this with text from technologies.htm. 

2. In the Files panel, open technologies.htm (It’s in the content folder). 
3. Select all the text, copy it, and then switch back to Dreamweaver.  Paste this text into the empty Content 

region of the untitled file. 
4. Title the page “Assistive Technologies | Universal Design” 
5. Select File > Save As. Name the file technologies.html. 
6. Choose File > Close All. 

When a file is based on a template, you will see a yellow label and outline around the design window. 
 

 
Figure 5: Label indicating a file based on a template 

Repeat this process with contact.html. 

Feel free to include your own contact info. 

Synchronize and check in browser 

Changing the template 
Open index.html and try to change the title from “Universal Design” to “Dreamweaver 2” 
You cannot change anything 

1. Open up index.dwt 
2. Change Design to Designs 
3. Add a link to University of Florida 
4. Save and update pages 
5. Switch back to index.html 
6. Save changes 
7. Synchronize site 

Notes: 
 
 


